Thinkific App: Account Management Service Disruption

Incident Report for Thinkific

Resolved

The issue is resolved and all pages now load successfully.
Posted May 01, 2026 - 20:28 PDT

Identified

We are currently experiencing a service disruption with our Account Management page at /manage/account.
Users may be affected and notice a 500 error when accessing the Account Management page. This can happen when attempting to view or manage your current Billing information.

This appears to be caused by an upstream provider that we integrate with being down. We're investigating for a solution and awaiting a resolution on their end. We will provide an update as soon as possible.
Posted May 01, 2026 - 17:00 PDT
This incident affected: Thinkific Application.