Intermittent issues with pages loading due to Netlify issues
Incident Report for Thinkific
Resolved
Our engineers have implemented a fix and everything is now back to normal. The issue is now resolved.
Posted Nov 04, 2019 - 12:22 PST
Investigating
A 3rd party provider, Netlify is currently experiencing intermittent issues. This is causing a decreased load speed on Thinkific sites and some icons to not load.

Their team is aware of the issue and will be posting updates on their status page here: https://www.netlifystatus.com/
Posted Nov 04, 2019 - 10:07 PST
This incident affected: Thinkific Application.