Thinkific Is Experiencing a Reduction in Responsiveness
Incident Report for Thinkific
Resolved
This incident has been resolved.
Posted May 25, 2022 - 16:52 PDT
Monitoring
A fix has been implemented and we are now monitoring the results.
Posted May 25, 2022 - 13:54 PDT
Investigating
Some students are unable to complete Course purchases from the checkout. Our engineers are aware of the problem and are investigating it.
Posted May 25, 2022 - 13:53 PDT
This incident affected: Thinkific Application.