Experiencing intermittent issues uploading videos - Resolved
Incident Report for Thinkific
Resolved
Some sites were experiencing issues with video uploads failing. If your video recently failed during the upload, please try again or get in touch with our support team if you're still having troubles.
Posted Dec 01, 2018 - 15:03 PST
Investigating
We have received reports of some video uploads failing for customer and are currently investigating.
Posted Dec 01, 2018 - 13:30 PST