Intermittent issues with uploads

Incident Report for Thinkific

Resolved

We’re happy to let you know that the file upload issue has now been fully resolved. Our third-party vendor, Filestack, has restored service, and uploads across the Thinkific platform should be working as expected.

Thank you for your patience while this was being addressed. If you continue to experience any issues, please don’t hesitate to reach out.
Posted Jul 07, 2025 - 06:47 PDT

Identified

Some users may experience intermittent issues uploading different files in various parts of the Thinkific application. We have identified the issue and it relates to a third-party vendor we use to manage uploads, who is currently experiencing degraded performance and intermittent issues in this area.
We will monitor the issue and update once it has been resolved on their end.
Posted Jul 06, 2025 - 08:50 PDT
This incident affected: Filestack API.