Webhook Events Are Delayed
Incident Report for Thinkific
Resolved
All webhook events are delivering at regular speed now. Thanks for your patience!
Posted Sep 03, 2021 - 11:05 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 03, 2021 - 11:04 PDT
Monitoring
Our team has implemented a fix and we've processed all backlogged events. Webhooks delivery times are returning to normal and our team will continue to monitor.
Posted Sep 03, 2021 - 10:46 PDT
Update
We are continuing to work on a fix for this issue. Thanks for your patience!
Posted Sep 03, 2021 - 08:09 PDT
Identified
We've identified the issue which is causing delays up to ~60 minutes for the delivery of webhook events. Our team is working to speed up the processing time and get through the delayed events and we'll post an update once we have more information.

While the webhook events are delayed, they are still sending as expected - events are not lost and will retry as usual if necessary.
Posted Sep 02, 2021 - 22:56 PDT
Investigating
We are currently experiencing delays with all webhook events. Thank you your patience while we investigate this issue.
Posted Sep 02, 2021 - 18:02 PDT
This incident affected: Thinkific Webhooks.