www.thinkific.com Is Down - We've Identified the Problem
Incident Report for Thinkific
Resolved
The issue is resolved. Our website at www.thinkific.com is up and running now.
Posted Mar 01, 2024 - 14:16 PST
Identified
Part of our website at www.thinkific.com is currently down. Our engineers have identified the problem and are currently implementing a solution. Everything should be back to normal soon!
Posted Mar 01, 2024 - 13:50 PST
This incident affected: Thinkific.com.