Thinkific Is Experiencing Delays in Some Services - We've Identified the Problem

Incident Report for Thinkific

Resolved

The challenges affecting our platform have now been resolved. Orders are processing correctly, videos are uploading successfully, and notifications are sending as expected.

Thank you for your patience.
Posted Oct 20, 2025 - 04:06 PDT

Monitoring

We are observing recovery across most of the affected services. Videos are uploading and processing, Orders are being fulfilled and notifications are being sent out. We will continue to monitor the situation closely to confirm a full resolution.
Posted Oct 20, 2025 - 03:27 PDT

Identified

Thinkific is currently experiencing delays in several of our services including fulfilling student orders and sending student notificaitons. Our engineers have identified the problem being due to disruptions with Amazon Web Services (https://health.aws.amazon.com/health/status) and are currently reviewing the situation.
Posted Oct 20, 2025 - 01:55 PDT
This incident affected: Thinkific Application.