Thinkific Is Experiencing a Reduction in Responsiveness
Incident Report for Thinkific
Resolved
Thinkific is back to normal and the issue has been resolved. Thanks for your patience!
Posted Mar 20, 2020 - 12:10 PDT
Investigating
Thinkific is a little slow serving requests at the moment on our admin dashboard and student facing pages. Our engineers are aware of the problem and currently investigating.
Posted Mar 20, 2020 - 12:04 PDT
This incident affected: Thinkific Application.