Users Page is Down
Incident Report for Thinkific
Resolved
This incident has been resolved.
Posted Aug 23, 2023 - 16:29 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 23, 2023 - 16:22 PDT
Identified
The Users Page is currently down. Our engineers have identified the problem and are currently implementing a solution. Everything should be back to normal soon!
Posted Aug 23, 2023 - 14:14 PDT
This incident affected: Thinkific Application.