Some pages are inaccessible with a Cloudflare error

Incident Report for Thinkific

Resolved

Cloudflare confirmed that its services are currently operating normally. No further errors should appear when trying to access pages.
Posted Nov 18, 2025 - 11:28 PST

Monitoring

Our third-party provider Cloudflare had an incident causing some pages to be inaccessible with an error Please unblock challenges.cloudflare.com to proceed. They just implemented a fix, but they are continuing to monitor this.
Posted Nov 18, 2025 - 06:48 PST
This incident affected: Thinkific Application, Thinkific.com, and Thinkific Help Center.