Thinkific Is Down
Incident Report for Thinkific
Resolved
Thinkific had a brief period of downtime, but we are back up and everything is functioning normally now.
Posted Jul 11, 2019 - 05:43 PDT
Monitoring
The Thinkific application is back up and we are monitoring the situation closely.
Posted Jul 11, 2019 - 04:21 PDT
Investigating
Thinkific is currently down. Our engineers are currently investigating the cause. We should be back soon!
Posted Jul 11, 2019 - 03:22 PDT
This incident affected: Thinkific Application.