Thinkific Payments is experiencing issues related to creating new accounts and updating existing account information

Incident Report for Thinkific

Resolved

This incident has been resolved.
Posted Feb 01, 2024 - 10:59 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2024 - 10:46 PST

Identified

Creators using Thinkific Payments are currently unable to update their account details. Users trying to set up Thinkific Payments will be temporarily unable to do so.
Posted Feb 01, 2024 - 10:11 PST
This incident affected: Thinkific Application.